There are a lot of different variants of the Pixelmania plugins available on the downloads page. This page will help you pick the right one for your particular use case.

We provide versions for both Linux and Windows (there are no MacOS versions, sorry), and for all versions of Nuke between Nuke12.0 to Nuke13.1 (NNSuperResolution is also available for Nuke11.3).

NNSuperResolution is Nuke Indie compatible from Nuke 12.2 and above. NNFlowVector is currently not Nuke Indie compatible.

First off, you really want to use a GPU accelerated version because the speed difference compared to the CPU only version is significant (around 50x according to our own testing). The CPU only version is provided for cases where you really need it even if it’s slow (maybe you got a large farm, without GPUs, and you still want to use the plugins). To be able to use a GPU accelerated version you need to have a supported NVIDIA GPU installed in your workstation. We currently support GPUs which support CUDA compute capabilities¬†3.5 (Kepler), 5.0 (Maxwell), 5.2 (Maxwell), 6.0 (Pascal), 6.1 (Pascal), 7.0 (Volta), 7.5 (Turing), 8.0 (Ampere) and 8.6 (Ampere). To check if your particular GPU is compatible, please check the “GPUs supported” section on the CUDA Wikipedia page: https://en.wikipedia.org/wiki/CUDA

You now got to choose between what CUDA version to run. In general, you can say that the higher version (more modern version) the better. They are always backwards compatible so no real worry of running a too new CUDA version. The only important thing is that you need to make sure that your graphics driver version is supported. The later CUDA version, the higher requirement on the graphics driver version. To guide you here, we do list what version of the graphics driver (both for Linux and Windows) you at least got to have on the downloads page.

If you have a very modern GPU, like the RTX30xx series, or perhaps the RTX A4000 card, you have to use the CUDA11.2 build. Basically there are some restrictions on the lowest CUDA version you can use for each card to be supported. In practice this means that you shouldn’t run a way older CUDA version than what was released around the time the cards hit the market.

We provide both downloads that include the CUDA & cuDNN libraries mentioned as requirements, and downloads that don’t include these. This is because they are pretty large in file size, so there might be occasions where you know that you got the needed CUDA libs already and do want to download a version of the plugins without. In general you SHOULD download the versions that do include the CUDA & cuDNN libraries because they are needed to run the plugins. To be clear, those exact versions are needed, so even if you got a CUDA11.0 Toolkit installed on your system and you download a CUDA11.0 build, the system CUDA needs to exactly match in version numbers to what the plugins are compiled against (this also applies to the cuDNN libraries). So to make sure this requirement is matched, it’s best and easiest to just download the bundled libraries and it shouldn’t be any problems.

A couple of example scenarios:

  • You got a RTX3080Ti card on Linux: You should download the CUDA11.2 version that includes the CUDA libraries, and pick the Nuke version you want to use it with. Make sure to have at least v460.27 of the NVIDIA graphics driver installed.
  • You got a GTX1080 card on Windows: You can download any of the CUDA versions that includes the CUDA libraries, and pick the Nuke version you want to use it with. Check your NVIDIA driver version installed and choose version based on that; If you got v426.0 or higher, but lower than v460.89, then pick the CUDA10.1 version. If you got a higher driver release than v460.89, then go with the CUDA11.2 version. If you got a lower driver version than v426.0, you need to update your NVIDIA graphics driver first before running our plugins.